root/lang/python/pytc/setup.py @ 1990

Revision 1990, 0.6 kB (checked in by tasuku, 6 years ago)

moved pytc repository from brazil to CodeRepos?

  • Property svn:executable set to *
Line 
1#!/usr/bin/env python
2import sys
3from distutils.core import setup, Extension
4
5if sys.version_info < (2, 3):
6  raise Error, "Python 2.3 or later is required"
7
8ext = Extension('pytc',
9                libraries = ['tokyocabinet', 'z', 'pthread', 'm', 'c'],
10                sources = ['pytc.c'])
11
12setup(name = 'pytc',
13      version = '0.1',
14      description = 'Tokyo Cabinet Python bindings',
15      long_description = '''
16        Tokyo Cabinet Python bindings
17      ''',
18      license='BSD',
19      author = 'Tasuku SUENAGA',
20      author_email = 'gunyarakun@sourceforge.jp',
21      ext_modules = [ext]
22     )
Note: See TracBrowser for help on using the browser.